Wednesday, May 25, 2022

[RESOLVED] Exchange 2016 CU X failed to install error 1619

During an Microsoft Exchange 2016 (for example CU3 to CU4) upgrade you got the error 1619. The full error would look like the following:

PS F:\> Setup.exe /mode:Upgrade /IAcceptExchangeServerLicenseTerms

Welcome to Microsoft Exchange Server 2016 Cumulative Update 3 Unattended Setup

Languages
Management tools
Mailbox role: Transport service
Mailbox role: Client Access service
Mailbox role: Unified Messaging service
Mailbox role: Mailbox service
Mailbox role: Front End Transport service
Mailbox role: Client Access Front End service

Performing Microsoft Exchange Server Prerequisite Check

    Configuring Prerequisites                                                                                                                                     COMPLETED
    Prerequisite Analysis                                                                                                                                         COMPLETED

Configuring Microsoft Exchange Server

    Language Files                                                                                                                                                COMPLETED
    Restoring Services                                                                                                                                            COMPLETED
    Language Configuration                                                                                                                                        COMPLETED
    Exchange Management Tools                                                                                                                                     COMPLETED
    Mailbox role: Transport service                                                                                                                               COMPLETED
    Mailbox role: Client Access service                                                                                                                           COMPLETED
    Mailbox role: Unified Messaging service                                                                                                                       COMPLETED
    Mailbox role: Mailbox service                                                                                                                                 FAILED

The following error was generated when "$error.Clear();
 Install-MsiPackage `
 -PackagePath ([System.IO.Path]::Combine($RoleLanguagePacksPath,
"Setup\ServerRoles\UnifiedMessaging\MSSpeech_SR_TELE.ca-ES.msi")) `
 -PropertyValues ("ARPSYSTEMCOMPONENT=1 ALLUSERS=1") `
 -LogFile
([System.IO.Path]::Combine($RoleSetupLoggingPath, "InstallSpeech-ca-ES.msilog"))
 " was run: "Microsoft.Exchange.Configuration.Tasks.TaskException: Couldn't open package
'C:\Program Files\Microsoft\Exchange Server\V15\bin\Setup\ServerRoles\UnifiedMessaging\MSSpeech_SR_TELE.ca-ES.msi'. This installation package could not be opened. Verify that the
package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package. Error code is 1619. --->
System.ComponentModel.Win32Exception: This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor
to verify that this is a valid Windows Installer package
 --- End of inner exception stack trace ---
 at Microsoft.Exchange.Configuration.Tasks.Task.WriteError(Exception
exception, ErrorCategory category, Object target, Boolean reThrow, String helpUrl)
 at Microsoft.Exchange.Configuration.Tasks.Task.WriteError(Exception exception, ErrorCategory
category, Object target)
 at Microsoft.Exchange.Management.Deployment.InstallMsi.InternalBeginProcessing()
 at
Microsoft.Exchange.Configuration.Tasks.Task.<BeginProcessing>b__5()
 at Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean
terminatePipelineIfFailed)".


The Exchange Server setup operation didn't complete. More details can be found in ExchangeSetup.log located in the <SystemDrive>:\ExchangeSetupLogs folder.
PS F:\>

 

To solve the issue you need to perform now the following steps on the affected Exchange Server:

1a.) Open the registry and navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v15\UnifiedMessagingRole

1b.) Create a backup from the Watermark registry key

1c.) Delete the watermark registry key

2a.) Open a file explorer and browse to C:\Program Files\Microsoft\Exchange Server\V15\UnifiedMessaging

2b.) Inside that folder the subfolder “grammars” and “prompts” should be missing. If that is the case you need to create them.

Optional: As the folder are empty you might restore the content now from a backup or if you do not have a backup you might try to copy the files from a Exchange server with the same patchlevel which do not have this issue. However in most cased the content isn´t needed as the upgrade should copy them from the ISO.

2c.) Re-Run the upgrade in a CMD (via run as admin):

Setup.exe /mode:Upgrade /IAcceptExchangeServerLicenseTerms

 

Note:

Some blog posting mentioned to copy the setup folder from the Exchange 2016 ISO to C:\Program Files\Microsoft\Exchange Server\V15\bin\. However this temp. will work as well. However during the next CU installation, this will cause the issues reported here due to the wrong files. So if you run into the error 1619 you should try the solution above at first.

Related Articles

LEAVE A REPLY

Please enter your comment!
Please enter your name here

Stay Connected

23FollowersFollow
- Advertisement -

Latest Articles