Problem: You are trying to mount a SharePoint content Database but got the error message "This content database has a schema version which is not supported in this farm." as seen below:

Mount-SPContentDatabase : This content database has a schema version which is not supported in this farm.
At line:1 char:1
+ Mount-SPContentDatabase "SharePoint_Farm_Content" -DatabaseServer ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
~~~
    + CategoryInfo          : InvalidData: (Microsoft.Share...ContentDatabase:
   SPCmdletMountContentDatabase) [Mount-SPContentDatabase], SPUpgradeException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletMountContentDatabase

Solution: The issue often occurs when you are trying to attach a content database to a SharePoint Server which has a different version level as the current one. For example the former content database was attached to a SharePoint server which was running SharePoint 2010 with SP1. But the current new server has only a fresh 2010 installation without SP1. To solve that upgrade your SharePoint 2010 Server as mentioned for example here.

Leave your comments

Post comment as a guest

0

Comments

    • No comments found