Abstract: When you try to browse a Exchange 2016 DAG via HP Data Protector you might got an error message that HP Data Protector isn´t probably configured.

The full full error looks like:

"Data Protector is probably not configured for use with MS Exchange Server 2013 on this host. Failed to configure MS Exchange 2010+ integration. *RETVAL*8010"

In the logfiles you can find:

[ 30] [CPowerShellInterface::Core] Failed to initialize PowerShell objects.
[ 99] 2016-09-15 12:56:54.177 ("$PATH: integ/exch2010/PowerShellInterface.cpp $ $Rev: 33960 $ $Date:: 2012-10-04 03:47:58 -040":126)
[ 99] <<=== (3) }  /* CPowerShellInterface::Core */
[ 99]
[ 30] [CPowerShellClient::CheckUserBelongsToGroup] Failed to CheckUserBelongsToGroup 'exbacktask.1': Could not load file or assembly 'System.Management.Automation, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

 

This could have the following reasons:

 

1.) The needed .net Framework (currently HP Data Protector support only 3.5.*) version is not installed

Keep noted that Exchange 2016 require .net Framework 4.5 or above as as mentioned here or here.

2.) The needed powershell engine 2.0 is not installed. The error message above mentioned version "1.0.0.0" but powershell 2.0 is the preferred option in this scenario.

Keep noted that Exchange 2016 require the powershell 4.0 engine as mentioned here or here.

So make sure both are installed additional to the one which are required for Exchange 2016.

 

Leave your comments

Post comment as a guest

0

Comments

    • No comments found