When you use Google Chome and try to use Microsoft Exchange Outlook Web Access (OWA) you will get an error message like ERR_SPDY_INADEQUATE_TRANSPORT_SECURITY. This is caused by a wrong MS Exchange / Windows OS configuration. To solve that you need to perform the following steps.

Read more: [RESOLVED] Error ERR_SPDY_INADEQUATE_TRANSPORT_SECURITY when using Google Chome and OWA